Views:

Yes, both the Konnekt and PowerCore series of products are compatible with SP3. If you are using a Konnekt or FireWire-based PowerCore you should install this Microsoft hotfix