Views:

Yes, this unit is compatible with all versions of Studio One up until 4.5.3. From this version onwards, PreSonus have notorized their software, meaning it has been prepared for Catalina. This causes a compatibility issue with our plug-ins. Our development team are working on a solution for this, but in the meantime you may want to consider using an older version of Studio One in order to use these plug-ins.