Views:

Unfortunately no. 
The TC range of interfaces are now long discontinued and as such the device may not connect or be compatible with more recent operating Systems. 

The Last updates were released in 2016 so we cannot guarantee compatibility with any operating system that was released after 2016. 

There are no plans to update the TC Near panel or drivers for these devices.